Page 1 of 1

Good-for-nothing laborers!

Posted: Sat Mar 14, 2009 7:41 pm
by The Sage Nabooru
I don't know how to post a savegame, so here's my situation.

Once upon a time, my laborers worked. I have several temples, stele for all my achievements, statues, and a pyramid in progress. They did their duties happily. I've got two overseers and they managed to get everything done.

Then, for some reason, they stopped. I'm building a cult temple and there's one measly block left to be placed on my pyramid, and the overseers visit these sites regularly, but apparently the laborers decided they're just not hauling anymore. Now I've got my overseers waiting at the cult temple and the pyramid, and the limestone block and statue sitting in their respective cargo drop-off points, and my laborers sitting around doing nothing. They stay in their houses. I tried building some more closer to the worksites, but to no avail.

Posted: Sat Mar 14, 2009 10:42 pm
by Azeem
Use the "Manage Attachments" button at the "Additional Options" section when you post.

It'd be easier if we could see what's going on in a save. :)

Posted: Sat Mar 14, 2009 11:13 pm
by Rnett
Insert image.jpg

Posted: Sat Mar 14, 2009 11:47 pm
by Tinkerbell
Howdy, The Sage Nabooru!

I hope your game is patched to at least v1.2. ;) I also hope you don't have a limestone block under water from deleting barge landings. How's the game lag? If no change it should be easily fixable.

I would love to see your game save. As Azeem posted, use the Manage Attachments option below the posting box. Pick the first slot & browze to your Game Save folder in My Documents after v1.2 or in the game files v1.2 or earlier.

Posted: Sun Mar 15, 2009 12:59 pm
by sakasiru
I had a similar problem once.

One way or another, I think there's somewhere a limestone sled dedicated to bring the last stone, but it doesn't, f.e. the sled is sunk to the bottom of the nile. (I once had an *empty* sled the workers didn't want to haul but they also refused to take another one of the 200 stones :rolleyes: )

It *may* help if you delete all your worker homes, thus freeing them of their current tasks. This only helps if the workers are not actually hauling the broken sled yet. Then build four worker homes again and hope they pick an unstuck stone.

Posted: Sun Mar 15, 2009 4:03 pm
by The Sage Nabooru
All right, here's my savegame.

I do know some blocks are underwater so I'll have to see to that.

I downloaded the game just two or three days ago, will I still need the patch? I got the whole set with Alexandria and all.

Posted: Sun Mar 15, 2009 7:04 pm
by Tinkerbell
Howdy again, The Sage Nabooru!

First of all, can you please tell me where you downloaded the game from? Which company or site for my Labs? Thankx in advance. This has nothing to do with your problem, by the way.

Your save loads in year 31 of E2 Bubastis (ugh) played on Normal Difficulty on v1.3/1.3.01 w/o Alexandria installed. This means that your game is patched & current. You just did not play with the XPac Alexandria. I use Steam & can play either way.

I have only played your save up to the point where you are stuck needing only one fine limestone block to complete your pyramid & the triggered FL block is underwater next to a landing on the western island. You can tell this is the one triggered by the pyramid by clicking on it & then holding down the shift key. You will see a triggering line that goes to the pyramid.

Bubastis is a terrible map for barging limestone across the river, due to all the small islands/waterways & the COTN triggering mechanism. It should be avoided at all costs. Place a dedicated DOP where you want the pyramid to be built & dedicate it. It was bad enough with v1.2 & v1.3 made delivery to barge landings a bit worse. We can now have problems with both imported basalt & granite also. ;) Please keep in mind that this is very rare & is due to the way you built. You may never see this again!

I can play Bubastis & build a pyramid in the exact same place & build a city exactly like you did, barge limestone across the Nile & not have a problem, but I know what to watch out for. ;) These specific situations are rare & sometimes you can get away with them & sometimes not.

Basically, COTN has never handled barging limestone across the Nile very well unless the player is very careful how to do it & should be avoided at all cost to be safe. VSP are usually fine & can be done anywhere including barging. It is the larger ones.

Possible causes

1) Plaza roads going up to landings removing unloading space from the game mechanism. Try not to do this. Leave one tile blank area completely around all landings.

2) Various piers being placed too close together. I don't think this is necessarily the cause of your problem, but farther south on that island, you have two piers too close together. Avoid doing this. It is the placement of the DOP & not the landing that is important, so landings can be placed quite far from your city & this is what I do. Same with shipwrights for different problems, but I place this one in my city cuz it needs goods & services.

3) DOPs too close to landings & also too close to water. Yeah, I realize that Bubastis doesn't give you a lot of room to build, but...

4) Any deleting of triggered DOPs or landings in the middle of a process. I cannot tell whether or not this has happened with your save, until I rip it apart further. Even then, I might not be able to tell. Deleted piers leave scars, but not all the time & you can rebuild on top of a scar & erase the evidence.

5) Too many DOPs used & possible rededicating too much. I use very few DOPs. I also leave a space between each one & never place them next to each other.

You have one abandoned limestone block on a sled & two basalt statues also abandoned. Abandoned stuff on sleds are never a problem in the game unless they are underwater.

Your pyramid might be dead & need to be deleted, but I have a few options in my bag of tricks to try, but I would need more time to try them. I just wanted to give you a report back. If no lag causes the game to crawl to a stop from being in an endless loop, you can just ignore the dead pyramid & continue on to win the scenario. Deleting the pyramid will untrigger the water block & it will remain but be removed from the game & never triggered again.

It is the map & not really the game. Various scenariomakers have found the same problems with their maps & their beta-ing doesn't show problems due to the way they play. Someone else builds their city a different way in a different location (specific buildings in certain locations) & problems occur.

One other thing for the moment. You have blocked doors by not turning your buildings properly. Every building should have a road or space in front of their doors. Click-hold-drag to place buildings & the red arrow will be the direction people leave the building. You can also use the R key to rotate before placing. This did not cause your problem.

You can really smash buildings together, but they should only be in x2 rows back-to-back.

You are using your Overseer on Nearest Worksite. Try to avoid using this function cuz it is uncontrollable. Use one of the Construction options. This however, did not cause your problem.

Posted: Mon Mar 16, 2009 2:42 pm
by CatMajik
I have had issues with laborers before. They would leave single blocks in the city, just seem to drop them off in the wrong places and never retreive them. Final pics suck with assorted blocks laying about. I can't delete them.

Posted: Mon Mar 16, 2009 6:24 pm
by tomnobles
Happens if you delete a barge landing and they were using it or going to use it (Triggered, that is). A DOP deleted when triggered for delivery will sometimes cause them to leave the sledge and never return. Shift Click on sledge and it will show if it is triggered for delivery and where it was going.

Posted: Tue Mar 17, 2009 1:03 pm
by CatMajik
"tomnobles" wrote:Happens if you delete a barge landing and they were using it or going to use it (Triggered, that is). A DOP deleted when triggered for delivery will sometimes cause them to leave the sledge and never return. Shift Click on sledge and it will show if it is triggered for delivery and where it was going.

Thank you :D