Steam / Vista / CotN crashs when starting campaign

For any technical or performance issues
Mazian
Posts: 3
Joined: Fri Jul 11, 2008 6:34 pm

Steam / Vista / CotN crashs when starting campaign

Postby Mazian » Fri Jul 11, 2008 7:07 pm

While I've attached my dxdiag.txt for verification purposes, please keep in mind that the problem I'm describing is based on a known issue (see Sticky: Known issues in the Enhanced Edition).

When I attempt to launch the game, I am able to successfully launch it and play the tutorials. However, when I attempt to launch a campaign, the game crashes.

The reported fix is to change the compatibility options on the game (CoTN.exe) to "Run as Administrator," which I attempted.

Then I receive the following error:
Steam - Error
This game is currently unavailable.
Please try again at another time.

I've reviewed and attempted all solutions under the Steam support page Reference 4595-WEXN-6831, however, none of the solutions (not even completely re-installing Steam per the instructions given) provides a solution. I've also tried rebooting, just for good measure.

When I remove the "Run as Administrator" option from the CoTN.exe file, the game will launch again normally, but will still crash when launching a campaign.

I would appreciate your assistance.


Before anyone suggests that the problem is Vista, keep in mind that if I had a way of reverting my email (Windows Mail in Vista) back to Outlook Express, I would, but since I don't, there's no point crying over spilled milk or spouting rhetoric about how bad Vista is. Reality: I have Vista. Reality: As far as I know, I can't go back. Reality: I have enjoyed CoTN and would like to be able to play the campaigns.

Let's work with what we've got (Sorry, but I've been reading some of the community's troubleshooting posts on other Vista user's issues and I'm not interested in wading through the painful rhetoric I've read in other posts just because someone has a bone to pick about Vista.)
You do not have the required permissions to view the files attached to this post.
Last edited by Mazian on Fri Jul 11, 2008 7:17 pm, edited 1 time in total.
Reason: Addendum

Mazian
Posts: 3
Joined: Fri Jul 11, 2008 6:34 pm

Postby Mazian » Fri Jul 11, 2008 7:24 pm

Workaround discovered:

While reading this thread, I found a suggestion from Keith to attempt running the game by directly launching the CoTN.exe.

I tried this and the game launches AND allows me to start campaigns. (NOTE: CoTN.exe is configured with "Run as Administrator" and will not launch campaigns without it, but launching CoTN.exe directly allows me to launch the game with "Run as Administrator" bypassing the error I get when I try to lauch the game through Steam.)

This appears to be a problem with Steam, but since CoTN crashes without "Run as Administrator" I'm not sure that Steam support would do anything about it.

If someone from TM could please advise whether I should open this as a ticket with Steam Support, I would appreciate it. I'm happy to report the problem to them, but this seems to be something that TM & Steam need to work out internally.

Will Jennings
Posts: 216
Joined: Fri Apr 07, 2006 9:47 pm
Contact:

Postby Will Jennings » Fri Jul 11, 2008 7:40 pm

Thanks very much for the detailed report, Mazian. I'm in contact with Valve about the issue, and I'll add that information to the workaround I posted.

Jahzoo
Posts: 88
Joined: Sat Jan 08, 2005 3:30 am
Location: Victoria, BC

Postby Jahzoo » Thu Sep 25, 2008 4:26 am

I recently downloaded the update and now I can't start CotN. I have downloaded the newest DirectX files - several times now - but still CotN will not load. Attached are my DXDiag files.
You do not have the required permissions to view the files attached to this post.


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 2 guests