Page 1 of 1

can't run game

Posted: Mon Jul 27, 2009 9:06 pm
by was1duke

I am having problems with Children of the Nile that I purchased through Impulse

When I attempt to run the program, it crashes immediately after
"please wait" appears on the screen

I am running on Windows Vista with 2GB of memory, a T5600 CPU at 1.83Ghz

I went to the Children of the Nile web site and based upon their
instructions, I re updated Direct X and also uninstalled and
reinstalled Children of the Nile. i increased the page file form 3072
to 8192MB

i also am using Mcafee anti virus and did a full scan as well as using

Could you please offer suggestions on how to get the program running properly ?

much thanks

Posted: Mon Jul 27, 2009 10:01 pm
by mouse
Your video driver needs to be updated to at least mid-2008. Did you download and install DX 9c which is needed by the game.

still no joy...

Posted: Tue Jul 28, 2009 1:06 am
by was1duke
thanks for your suggestions

I'd upgraded the nvidia driver
and I ran the aug 2008 directx installer which ran and said it updated a bunch of files
and applied Vista SP2
i also (based on some other posts) tried the 800x600 and 1024x768 screen resolutions before i ran cotn

and the game still generates the same immediate crash after the "please wait" screen in all cases

More to Try

Posted: Tue Jul 28, 2009 9:11 am
by Phil Walker
Adding to what Mouse has noted, do know that Vista is a terrible resource hog. This is indicated by your pagefile usage, which means you have too much running in the background. I will address this in a bit though.

Your system might have conflicts with the in-game movie files. You might need to remove them. To do so, locate the CotN game folder and open it. Locate and open the Data folder, then locate and open the folder named Movies. Delete all files in that folder, but NOT the Movies folder itself or it may try to recreate the files. Try the game now and see if this helps.

I also hope that you installed the game on the built-in drive as CotN does not take too well to any add-on hardware. You should thus disconnect the external drive and try the game without it and see if this helps.

If not, let's tweak your background programs. To do so, follow these instructions:

1. Click on Start and select Run. (If you don't see Run depress your "r" key.) A window will open.
2. In the text window enter "msconfig" (without the quotes) and either click the OK button or depress your Enter key. The program will load.
3. Click on the Startup tab. This is your background list. I'm certain you have way too many checked. All you need are; your Anti-Virus/Firewall, your nVidia Control Panel (which includes the driver version number),any custom internet connection program, and any instant messaging program that you use. That is IT!
4. Uncheck all I did not list, click Apply, click Close. A window should appear. Close all windows and then either click on the Restart button or if no window click on Start, select Turn Off Computer, and then click Restart. You will reboot.
5. Upon reboot and getting back onto your account you might encounter a pop-up. If you do, put a check in the Do Not Show Me This Again box and click the OK button. Try the game now and let us know.

NOTE: If you use any messenger programs make sure to sign out before you play. You don't have to exit them, but do make sure to sign our as any pop-up may also cause a crash


still no luck

Posted: Tue Jul 28, 2009 6:21 pm
by was1duke
thanks for your help - the big page file was my first try following the game's support site suggestion of increasing it

i confirm the game is installed on the <C> drive in the default directory

since then,
i've deleted the sole file in the data/movies folder (there's only one?)
i've disarmed everything except mcafee, threatfire, nvidia (even though it would have been annoying to turn off my backup software)
i've yanked everything external except the mouse

and the game still crashes after the "please wait"

does anyone have some more ideas for next steps ? here's a new dxdiag

Posted: Tue Jul 28, 2009 10:58 pm
by Keith
Try a smaller screen resolution in the game. Check the install folder and see if there is a cotn.ini file. If there is open it using Windows Notepad. Locate the line that says Full Screen Mode 1 and change the 1 to a 0.
Change the lines for Game Window Height xxx and Game Window Width xxxx (where x=the screen height and width). Change the value to 768 height and 1024 width.

Save the file as cotn.ini in the same folder. Make sure it doesn't get named cotn.ini.txt. If it does just edit the fileaname.

The nVidia Go 7300 card is somewhat limited and may be having problems with the other settings you have.

Try running the game and see what happens.

Not Done but Will Get Back Later

Posted: Tue Jul 28, 2009 11:15 pm
by Phil Walker
Will get back to you as I'm not one to give up. Know there are more steps and it sounds as if you have something else installed on your system that might be conflicting. It's happened before and could be the case now and often back-up programs and other protection programs as you noted are often the cause, but will be the last resort.


full screen mode no help...

Posted: Wed Jul 29, 2009 5:47 pm
by was1duke
Thanks for writing back

The change of the full screen mode setting to zero didn't help. Now it crashes without even doing the "please wait"
and the resolution was preset to 1024x768 by default (i also gave it a go at 800x600)

I attached the cotn.ini file

Much thanks for looking into this

Posted: Wed Jul 29, 2009 6:12 pm
by Keith
No cotn.ini file was attached to your post. You have to use the Manage Attachments button to upload the cotn.ini file to a reply message then when you post the message the file will be saved with it.

Changing those settings on the digital versions of the game don't seem to have any effect, but they do/did on the original CD retail version. It reduced the size of the screen the game had to render while the game was running and lightened the load on the video card processor. Sometimes this is all it took to help some of the less powerful video cards get over the "hump" and get the game running.

You can try renaming the cotn.ini file to cotn.old and let the game right a new default ini file as you start up. If the game continues to crash there has to be a problem with that digital version of the game you bought and you may have to badger Impluse to help you get the game up and running. Many of these digital resellers seem to have a sell-it-and-forget-it operation. If you are lucky, they will get their tech support people with you and solve the problem. If not, you may have pester them until they do.

The problem with the digital versions of the game is that they have altered some of the code to make it run without a CD and may have created a incompatability problem with something on your system, most likely some other software. If you are using any software from your previous machine on the new computer you may want to uninstall it and see if the game will then run.

Other options are to uninstall the game do a registry scan and clean with a progrom like Regseeker or CCleaner etc. I've used Regseeker myself and others have used CCleaner. Reinstall the game and try it again. Sometimes a bad install or corrupted registry entry can cause problems.

Posted: Wed Jul 29, 2009 6:28 pm
by was1duke
oops here's the attachment (ini files can't be attahed apparently so i renamed it txt)

i tried wiping out the cotn.ini file and rerun, still crashes

Posted: Thu Jul 30, 2009 12:00 am
by Keith
Your file is fairly similar to mine, but I have a few settings higher in mine than yours because I have a slightly more powerful video card and I also got my digital copies of the game via STEAM so there are a few entries regarding install path and save game path that are in my file that aren't in your file.

I dont really see anything major that would cause your game not to run in your file.

You may have to try some of the other steps I mentioned.