Performance Issue - CotN Enhanced from GOG

For any technical or performance issues
Honknatter
Posts: 2
Joined: Wed Aug 14, 2013 10:26 pm

Performance Issue - CotN Enhanced from GOG

Postby Honknatter » Wed Aug 14, 2013 10:41 pm

Hi there,

I recently purchased the Children of the Nile Enhanced Edition via Good Old Games and I am experiencing some severe performance issues. I'm running it on a Phenom II X4 955, Gainward GTX 275, 6GB Ram, Win7 x64 system, which is why it surprises me since it basically runs most of the current gen games still in a more or less acceptable way. I also watched some gameplay videos on youtube just to confirm that the low framerate performance I am currently experiencing is not common.

I tried reinstalling, which did not help at all. Of course I tried lowering the settings to the absolute minimum including turned-off sound. There was no change in performance whatsoever. However, scrolling after hitting escape with the menu popped up is absolutely smooth, just like its supposed to (I guess :D ). Whenever I exit the menu and reenter the game, it slows down to a rather unplayable stuttering mess again. Although I do not know exactly why ( :D ) I tried running it in administrator mode as well as several compatibility modes. No change whatsoever.

So I'm actually at a loss here. Web-search for related issues did not hit me up with anything similar either so this seems to be a rather singular problem. Like I said, I'm at a loss. Any suggestions?

Thanks in advance

Honknatter
Posts: 2
Joined: Wed Aug 14, 2013 10:26 pm

Postby Honknatter » Sat Aug 17, 2013 8:18 am

Fixed. Scaling was set to be performed on the GPU in the NVIDIA Control Center. Don't exactly know why. So I set it to "Display" and it works fine now.


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 2 guests