Windows 7 Runtime Error

For any technical or performance issues
MarcusMaximus
Posts: 12
Joined: Thu Sep 14, 2006 6:03 am

Windows 7 Runtime Error

Postby MarcusMaximus » Sun Jun 08, 2014 8:43 pm

After long last, I have moved "up" from Win XP to Win7 and am thoroughly hating the experience. I am attempting to use the 32-bit version for my old games as I find the newer games not to my taste.

I am getting the following runtime error with CotN when I start it:

The dialog box is titled "Microsoft Visual C++ Runtime Library"

The text reads:
Runtime Error!
(full path)\CotN.exe
abnormal program termination

Additionally, the CD/DVD drive doesn't open after this failure. I have to manually eject with a paperclip.

PCDania at the HG Forums suggested I install Microsoft Visual C++ Redistributable 2005 (2008, 2010, 2012 and 2013) and make sure it is fully updated on Windows Update. This did not resolve the issue.

I haven't uncovered anything here of a similar nature, so, any thoughts?

Keith
Posts: 9963
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Sun Jun 08, 2014 10:55 pm

Did you try setting the CaesarIV.exe file to windows XP compatibility?

There is also the Windows Program Compatibility Tool in the Control Panel to help get older programs running. You can have it try to adjust the settings on its own, or you can manually make some settings using the PCT.

Be sure you run the game in the Admin mode.

MarcusMaximus
Posts: 12
Joined: Thu Sep 14, 2006 6:03 am

Postby MarcusMaximus » Mon Jun 09, 2014 3:38 pm

Yep, yep and yep.

Are there any log files that might capture this error?

I'm not seeing any so far.

Keith
Posts: 9963
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Mon Jun 09, 2014 6:19 pm

Open the install folder for Caesar IV and double click on the RegisterDLL.bat file located there. Then try the game. See if you still have the problem.

You may also try opening the Control Panel and then "System and Security" (category view mode) then "System" (category view mode).

If you have your Control Panel setup in one of the icon view modes, you should open System on the Control Panel.

Next "Advanced System Settings" (left column of page) and the "Settings" button under the ADVANCED tab on the popup menu.

Click on the Data Execution Prevention tab on the "System Properties" menu.

Change the DEP by clicking the radio button next to the line "Turn on DEP For programs and services except for those I select". Click the ADD button and browse to the CaesrIV.exe file in the game's install folder and select it. Caesar IV should appear in the boxed area. Click APPLY and OK.

Try running the game.

If that doesn't work you can go back to the DEP menu. Select the REMOVE button and select Caesar IV in the boxed area. Change the radio button back to the default "Turn on DEP for essential Windows program and services only." Click APPLY and OK to reset it. Close the Control Panel window.

MarcusMaximus
Posts: 12
Joined: Thu Sep 14, 2006 6:03 am

Postby MarcusMaximus » Thu Jun 12, 2014 3:48 am

I'll try that when I get home. Travelling can be such fun.

I am also doing this with CotN, not C4. Hope it will be the same.


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest