welcome back forum

Anything relating to our company that doesn't fit elsewhere
vic_4
Posts: 2350
Joined: Fri May 07, 2004 9:11 am
Location: Rome Italy

welcome back forum

Postby vic_4 » Fri Nov 07, 2014 6:04 am

Happy that the forum is back. I hope next good new is an announcement. :D

PCDania
Posts: 236
Joined: Tue May 04, 2004 9:03 pm
Location: Denmark, Europe

Postby PCDania » Fri Nov 07, 2014 8:53 am

Congrats to Jeff and Chris for getting the forums online again :)

CatMajik
Posts: 665
Joined: Tue Jan 11, 2005 1:25 pm
Location: MajikWorld, NC

Postby CatMajik » Sat Nov 08, 2014 3:40 pm

Sooooooooooooooo glad you guys are back!!!! :D

llehsadam
Posts: 15
Joined: Mon Jan 28, 2013 9:40 am
Location: Germany
Contact:

Woohoo!

Postby llehsadam » Sat Nov 08, 2014 10:52 pm

Great! ... so ... what should we do now?

mouse
Posts: 1723
Joined: Thu May 06, 2004 5:21 am

Postby mouse » Sun Nov 09, 2014 11:43 am

Wow glad the forum is back. Was really concerned that it was lost :eek:

Azeem
Posts: 3678
Joined: Wed May 05, 2004 9:30 pm
Location: Hetepsenusret

Postby Azeem » Sun Nov 09, 2014 9:44 pm

Ah, it's back up. :D

Miut
Posts: 713
Joined: Tue May 04, 2004 4:00 pm
Location: West Coast USA
Contact:

Postby Miut » Wed Nov 12, 2014 4:04 am

We went down??? Glad we're back!

PantherX
Posts: 1111
Joined: Mon Nov 27, 2006 7:00 am
Location: The Beautiful Monterey Bay California

Postby PantherX » Wed Nov 12, 2014 5:19 am

Yeah, I was saddened when I got the 404 the other day thinking it was gone for good.

Glad your still here so far TM!
:cool:
:cool:

Keith
Posts: 9965
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Wed Nov 12, 2014 2:06 pm

Yep, there were some problems with the host server and the board. It took Jeff a while to get things sorted out.

Marius
Posts: 125
Joined: Wed Oct 05, 2005 10:01 pm
Location: Vancouver

Postby Marius » Thu Nov 13, 2014 1:13 am

Welcome back Romans .... there are many Lions who wish to eat ... oops meat ... oops meet you.

tomnobles
Posts: 1182
Joined: Sat Aug 25, 2007 12:01 am
Location: Albuquerque, New Mexico
Contact:

Postby tomnobles » Sat Nov 15, 2014 6:52 am

"Keith" wrote:Yep, there were some problems with the host server and the board. It took Jeff a while to get things sorted out.


They must be busy with something, hey?


Return to “The Tilted Mill”

Who is online

Users browsing this forum: No registered users and 2 guests