Caesar IV Menu and Game Mouse LAGG!

Everything Caesar IV that doesn't fit elsewhere
gabojosue
Posts: 5
Joined: Fri Jul 19, 2013 11:08 pm
Location: Costa Rica, San Jose

Caesar IV Menu and Game Mouse LAGG!

Postby gabojosue » Fri Jul 19, 2013 11:37 pm

I have a problem that makes it difficult to play the game normally, the thing is that the mouse is very slow, the response time is very slow, but when the game loads the maps the mouse has more response.

I can not have the drivers for keyboard and mouse, maybe it's why, but it works fine with other games, but this is not (Caesar 4), I thought it was for the game, but I checked every mouse issues page and I could not figure this out.

Obviously I have the recommended requirements, this game is the best I've seen, and I want to play it without problems.


I have Microsoft Windows XP Profesional SP3.
All Requirements of Caesar 4.


My DxDiag.txt for view or download: http://www.mediafire.com/download/i7n9wj7dg1w6m61/DxDiag.txt

:(
Last edited by gabojosue on Fri Jul 19, 2013 11:45 pm, edited 1 time in total.

Keith
Posts: 9951
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Sat Jul 20, 2013 2:44 am

What screen resolution are you running the game in? If it is an odd size like 1440x900, let's say for example, that might be causing a problem. Try a more normal screen res like 1024x768 or 1280x1024 and see if that helps. You will need to restart the game after resetting the screen res in the game's Video settings menu.

Does this mouse have it's own control panel software that runs in the system tray in the lower right corner of Windows?

If it does you may want to try disabling it. Some of these programs interfere with games and other software.

Make sure your mouse driver is the current one.

If none of that works, you can get a generic mouse driver from Microsoft, uninstall your current mouse driver and any mouse control panel software and install the MS driver.

gabojosue
Posts: 5
Joined: Fri Jul 19, 2013 11:08 pm
Location: Costa Rica, San Jose

Postby gabojosue » Sat Jul 20, 2013 4:44 am

I did my best, the highest resolution that I can put into the game is 1366x768, although I have the problem of slow, I have to buy another mouse or keyboard? and where I get the microsoft mouse driver?

Keith
Posts: 9951
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Sat Jul 20, 2013 11:01 am

You should be able to uninstall any current mouse driver and it's software and then let Windows detect and install the default mouse drivers during a reboot.

1366 x 768 is just the sort of odd resolution you should probably avoid. The two that I used as an example are more normal resolution settings. If it doesn't make any difference in the game performance you can always switch the in-game setting back to what it was.

You have computer setup for 1024x768. You don't necessarily want to change that at all. The setting I'm talking about is inside the game on the Settings menu.

Also, if you have any other input device hooked up like a joystick, a drawing pad, etc. You should try disconnecting that device and see if the mouse responds better in the game.

If you have a LCD monitor they have a tendency to refresh at 59hz instead of 60Hz. Make sure your monitor properties are set to 60Hz refresh rate.

You may also be experiencing V-sync lag. See this article on fixing it:
http://mystrd.at/articles/v-sync-mouse-lag-how-to-fix-it/

If all else fails try a in-game screen resolution of 800 x 600.

If this is a wireless mouse, you may need fresh batteries.

gabojosue
Posts: 5
Joined: Fri Jul 19, 2013 11:08 pm
Location: Costa Rica, San Jose

Postby gabojosue » Sat Jul 20, 2013 10:55 pm

Thanks Keith, I did everything that you gave me, but unfortunately still gives me trouble, I wonder how is that the V-Sync, I disabled this option in the game, but I see no changes ...

Keith
Posts: 9951
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Sun Jul 21, 2013 4:45 am

Here's an explanation of V-Sync (Vertical Synchronization):

http://www.tweakguides.com/Graphics_9.html

Your video and audio drivers are a year old. It might be advisable to update them.

I forgot to ask you what version of Caesar IV do you have? 1.0? 1.1? 1.2? You should have 1.2 if you don't. If you have an older version you'll need to get the update patch. The only place you can find it now is at a site like Caesar IV Heavens Games.

Close applications that you may have running on your system such as screen savers, virus scanners, desktop themes, animated cursors, etc.

To prevent extra applications and services from loading during startup please use the steps below:

-Click Start button then Run
-In the box type MSCONFIG and click OK.
-Select the Startup tab and then click Disable All button to uncheck these items.
-Click OK. When you are prompted to restart, click on YES.
-Upon reboot, your startup applications will not start, please try running the game.

To undo the above changes:
-Click Start then Run
-In the box type MSCONFIG and click OK.
-This will bring up the System Configuration Utility.
-On the general tab, click the dot next to Normal Startup.
-Click OK. When you are prompted to restart, click on YES.
This will restart your computer with all the background applications re-enabled.

If the lag goes away with the startups disabled, it means that one of them is the problem.

To figure out which one it is you have to re-enable one startup at a time, reboot, then try the game. If all is well and there is no lag, return to the MSCONFIG Startup menu and re-enable one more, reboot, and try the game. Just keep repeating that until you either finish re-enabling all the startups, or until your lag problem returns.

If the lag returns, it means that the last startup you re-enabled is the culprit.

You may find a program that your mouse is using on the startups list. I would try disabling that one first.

To return everything to normal just follow the UNDO steps listed above.

gabojosue
Posts: 5
Joined: Fri Jul 19, 2013 11:08 pm
Location: Costa Rica, San Jose

Postby gabojosue » Mon Jul 22, 2013 1:35 am

I did everything that you gave me, but the truth is I do not know why this problem did not go away, really do not know if it's because the little free space on my hard drive and have two partitions ...

I read the entire website about V-Sync, and I did everything to turn this off in the game as in other programs (nHancer) ... I do not know if I have to format the pc or not ... I updated video drivers and sound drivers.

I have the Nod32 Antivirus, Tune Up Utilities and USB Disk Security.

:(

Keith
Posts: 9951
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Mon Jul 22, 2013 4:14 am

I'm out of ideas for now. Did you try running the game from the SAFE MODE desktop?

The Safe Mode only startups up the necessary Windows functions to get the computer running.

You have to reboot the computer and before the computer beeps on the restart begin tapping the F8 function key until you get a black and white menu. On there you should see two Safe Modes, one with CD-ROM support. Select the one with CD-ROM support by typing the number next to it. Let the computer boot to the Safe Mode desktop.

Try starting the game and see if the lag goes away.

To get back to normal Windows desktop just restart the computer and let it startup like normal.

Keith
Posts: 9951
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Mon Jul 22, 2013 7:01 am

Two more thoughts I had on your problem.

Try unchecking all the boxes in the SETTINGS > INTERFACE menu under the Message Pausing section. These items include things like "Epidemics", "Fire and Collapse", etc. When these boxes are checked the game pauses when one of these messages popups up on the screen and you have to manually clear them each time.

These messages just might be causing your lag problem.

Next, in the SETTINGS > VIDEO options try lowering all of the settings a few notches. You can try a quick shortcut by choosing the 'BEST PERFORMANCE" in the Graphic Quality Presets section. Try the game.

If that seems to help, you can try the next higher setting. If things are still working well, you can try the next higher setting and so on until the lag returns then back off to the previous setting.

You can also try manually turning all the individual graphic settings in the Advanced Settings section OFF or set to minium. Try the game.

If it works better, select one of the settings only and raise setting slightly. Try the game. If things are still working well, go back and raise that same setting a little more. Try the game.

Repeat this until each setting has been raised to maximum or to the point where the lag returns.

Do the same thing with the Texture setings buttons along the bottom of the Advanced Settings menu. Start with them off. If the game works better, then try turning one setting on at Low. If the game still works well, then try the Normal/Medium setting next and so on.

When the first setting has been fully tried, then move the next one and repeat the entire process until you are at maximum or the lag returns.

I also recall that some people had problem with the "weather", lightning, rain, snow, etc. in the game. This caused crashes and performance problems on some machines. You can try editing the caesariv.ini file in the Caesar IV install folder on your hard drive.

Using a simple text editor like Windows Notepad to edit the last line in the file called "Weather". There should be a "1" after it indicating that the weather is enabled in the game. You can change that "1" to "0" (zero) to disable the weather.

Next, save the file as Caesariv.ini. Be sure that you don't have a .txt on the end of the save file so that it looks like Caesariv.ini.txt. If there is a .txt on the end just rename the file and remove the .txt from the file name. You have to exit the game and restart it if you edit this file while the game is running. See if that might cure your lag problem.

You can always change weather back by chaning the number back to "1" again.
Last edited by Keith on Mon Jul 22, 2013 7:08 am, edited 1 time in total.

gabojosue
Posts: 5
Joined: Fri Jul 19, 2013 11:08 pm
Location: Costa Rica, San Jose

Congratulations!

Postby gabojosue » Mon Jul 22, 2013 2:35 pm

Thank you very much for your support, now the mouse is having a better answer, because caesariv.ini and menu options, I can now play normally!
:) :) ;)

Keith
Posts: 9951
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Mon Jul 22, 2013 4:21 pm

I'm glad to hear that. :D


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest