Invalid save file???

For technical or performance related issues
Tetsuro Hoshino
Posts: 4
Joined: Tue Oct 24, 2006 8:23 am

Postby Tetsuro Hoshino » Tue Oct 24, 2006 4:37 pm

No, sorry, I shared with all my autosaves in zip-archieve. Actually, I have to start this scenario from the beginning... :(

But there aren't any gatehouses in my save, only massive towered wall against germans (I think it did that problem).

Will Jennings
Posts: 216
Joined: Fri Apr 07, 2006 9:47 pm
Contact:

Postby Will Jennings » Tue Oct 24, 2006 4:40 pm

Ach, bad Tilted Miller, no cookie! Right, I meant the towers.

it's back to Caesar IV building identification class for me...

Pappy
Posts: 2
Joined: Sun Oct 29, 2006 12:52 am

Thanks Doc

Postby Pappy » Sun Oct 29, 2006 1:03 am

Thank you DRDOAK. I bought Caesar IV from D2D, installed it and ran into the same save error and then runtime errors after that. I found this thread, did as instructed in the HKEY_CLASSES_ROOT and started playing. It's the first time I ever used D2D and thought I got screwed. Sounds like many people have this same problem. This fix should be stickyed IMHO.

Thanks again Doc! This is one happy patient!! :)

phil-maskell
Posts: 13
Joined: Mon Aug 21, 2006 8:41 pm
Location: Belgium

Postby phil-maskell » Mon Mar 03, 2008 2:47 pm

"Davidus Maximus" wrote:I received this game for my birthday two weeks ago and I have been trying to get this game to work up until last night. The fix above saved me and I no longer have to go home and curse at my computer anymore. Thank you DRDOAK for your post...you are a life saver. I wanted to write this so I could confirm that this works and fixed both the invalid save game problem and the runtime error, and also I wanted to lay out the steps sequentially and concisely for people like me that want to be absolutely sure of what they are doing before touching the registry. I believe that both of these issues are connected but it seems to be addressed in the forums as seperate issues. The first time I loaded the game everything seemed to be fine until I started the first scenario in the Kingdom campaign....as the game was loading at the splash screen I would get the "Invalid Save Game....etc." error and then it would kick me out :eek: . When I tried to relaunch the game I would then get the "C++ Runtime Error...This game has terminated in an unusual way...etc" message box or sometimes the game failed to launch at all. I tried everything that everyone else talked about such as updating drivers, defragging, runnning a registry cleaning utility, running Regmon but to no avail. :( The tech support hotline told me to uninstall the game, create a new user profile and load the game under that new profile. This was the official course of action as of last week. This was a complete waste of time. :mad: I followed the instructions of DRDOAK and about two minutes later plus a restart the game was up and running with no problems. :) The best thing about this fix is that it does not require you to actually change anything in the registry itself. I also did not have to reload the .net framework just like DRDOAK suspected. I will lay out the exact steps I took for the sake of clarity and hopefully this can help someone else. I hope somebody from Tilted Mill sees this and clues in tech support so they can stop giving out the wrong advice. Hopefully the are already aware of this fix.

Steps to fix Invalid Save Game/C++ Runtime Error problem

CAUTION: MAKING CHANGES IN THE REGISTRY COULD CAUSE CATOSTROPHIC PROBLEMS TO YOUR COMPUTER. DO NOT CHANGE ANYTHING WITHIN THE ACTUAL REGISTRY KEY ITSELF UNLESS YOU ARE AN EXPERT. THIS FIX ONLY REQUIRES YOU TO ADD A PROFILE AND SELECT PERMISSIONS LEVELS. DO THIS AT YOUR OWN RISK. IT IS RECOMMENED TO BACK UP YOUR REGISTRY PRIOR TO DOING THIS.

1.) From the start menu click run
2.) At the command prompt type: regedit
and then click on run
3.) A screen should pop up with directory screen similiar to the windows explorer
4.) Scroll through the directory tree until you locate the folder: HKEY_CLASSES_ROOT
4.)Right click on the folder and then click permissions
5.)Click on the Group or User name: ADMINSTRATORS (if it does not exist click on ADD then type in ADMINSTRATORS then hit OK. Then click on it. In my case there was only one group or user name available. It was called EVERYONE. I am not sure if this was how it always was or it got changed when I loaded the game. I am assuming that the game does not recognize a user name or group called EVERYONE so that is why the game would not run)
6.)Then click the "Allow" box for "Full Control".
7.) Click APPLY then OK and then close the regedit window.
8.) Restart the computer.
9.) Relaunch the game
10.) Enjoy the splendor and wonder of Rome. ;) Long Live Caesar!!!! :)

**Note: the user profile under which you are logged should have administrator rights...just to be safe!!

I think it would be a good idea to put this in the other forms discussing the Invalid Save Game and Runtime errors (C++ This program terminated unsually...etc). I am new at using this forum stuff so could somebody help me with getting the word out. Thanks.

I included my dxdiag for reference.

Once again DRDOAK is the bomb!!!! :)


Whilst this post may be a fix for XP anyone got roughly the same for Vista? I have been into the registry (reged32.exe) but trying to follow the scenario above does not work.

gentlemanbones
Posts: 1
Joined: Sun Feb 02, 2014 6:29 pm

Postby gentlemanbones » Sun Feb 02, 2014 7:13 pm

autosave turned off does not work

Keith
Posts: 9946
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Sun Feb 02, 2014 11:39 pm

"gentlemanbones" wrote:autosave turned off does not work


Are you having the same problem or is this just a comment?

What is your version of Windows?


Return to “Community Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest