game crash at a few occasions

For technical or performance related issues
darklordnd
Posts: 4
Joined: Mon Aug 02, 2010 7:28 am

game crash at a few occasions

Postby darklordnd » Mon Aug 02, 2010 7:39 am

My Caesar IV crashes every time I try to access the Labor advisor or Resource advisor. and out of those, it crashes at (seemingly) random times. I am really stuck with these crashes, especially the random ones, since if it happens I can't help it - load the game at an earlier savepoint and tried not to do anything, but when the time comes it still crashes.
I am using Windows 7 Ultimate 64 bit, with DirectX11 and DirectX9 runtime installed for the extra.
Please help! Many thanks to all.

Keith
Posts: 9965
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Mon Aug 02, 2010 4:56 pm

Be sure you set caesariv.exe to "run as administrator".

Run the registerdll.bat file located in the Caesar IV default installation folder.
To do that:
-Right-Click on Caesar IV shortcut icon on your Desktop and select Properties.
-Click on Find Target
-Locate and Double-Click on registerdll.bat file then press any key.
Try running the game again.

Close applications that you may have running on your system such as screen savers, virus scanners, etc.
To prevent extra applications and services from loading during startup please use the steps below:

-Click Start button then Run
-In the box type MSCONFIG and click OK.
-Select the Startup tab and then click Disable All button to uncheck these items.
-Click OK. When you are prompted to restart, click on YES.
-Upon reboot, your startup applications will not start, please try running the game.

To undo the above changes:
-Click Start then Run
-In the box type MSCONFIG and click OK.
-This will bring up the System Configuration Utility.
-On the general tab, click the dot next to Normal Startup.
-Click OK. When you are prompted to restart, click on YES.
This will restart your computer with all the background applications re-enabled.


If you have emulation software or a related virtual drive, such as: Alcohol 120%, Blind Write, Daemon Tools, Game Jack, Clone CD, Game Jackal, Xoom Game Clone, CD Space, Virtual 7 CD, Fantom CD or Anti Blaxx or similar installed you may need to either disable or completely uninstall this program or software as these types of applications are know to have conflicts with SecuROM.

You could also just have a bad install of the game. You may want to try uninstalling it then reinstalling Caesar IV. You can sometimes get a better install if you are having problems by doing the install in the Windows SAFE MODE.

I am not sure how it works on Windows 7, I have Windows XP here. But usually if you reboot, and then immediately start tapping (don't hold) the F8 before the system "beeps" in the restart process you should end up at a black and white menu. On that menu there should be a list of options, one of which is the SAFE MODE. Just type the number next to the SAFE MODE on your list and let the startup proceed.

Once at the Desktop in the SAFE MODE install Caesar IV. When the install is done reboot the system and let it start up normally and then try the game.

darklordnd
Posts: 4
Joined: Mon Aug 02, 2010 7:28 am

Postby darklordnd » Tue Aug 03, 2010 6:04 am

Thanks to Keith for the reply.
I did run registerdll.bat (for I had the runtime error problem before), I had no problem with my startup or background softwares, and I tried reinstalling Caesar IV several times before I ask here. I updated caesar IV to 1.2.
The problem is quite tricky for me and it discourages me from playing the game greatly. I hope someone would come up with a solution soon, and I'll be saved by then.

Keith
Posts: 9965
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Tue Aug 03, 2010 2:12 pm

Did you try "run as administrator" as I mentioned? Have you tried setting caesariv.exe to run in the XP compatability mode?

Try adding the caesariv.exe file to the Windows Data Execution Prevention exception list. I have Windows XP not Windows 7 so I don't know if Win 7 has it (probably does) or how you get to it (might be different than Windows XP.)

Find the Data Execution Prevention tool, then ADD the caesariv.exe file to the list. You will have to reboot the computer and then try running the game. DEP prevent malicious codes from taking control of the computer. Sometimes DEP detect code that it thinks is bad and shuts the app down.

You can remove caesariv.exe from the list later if it does not make any difference.

In Windows XP you get to the DEP function by opening the CONTROL PANEL.

Then open Performance and Maintenance (in the catagory view). Then open SYSTEM.

Click on the ADVANCED tab and the settings button in the Performance section.

Click on the DATA EXECUTION PREVENTION tab.

Put a mark in the button next to "Turn on DEP for all programs and services except for those that I select:"

Choose ADD and browse for your caesariv.exe file. Select it and click APPLY and OK. Reboot the computer. Try the game.

Is there some option on your Windows 7 64-bit OS to run applications in a 32-bit mode? Try that if there is.
Last edited by Keith on Tue Aug 03, 2010 3:00 pm, edited 1 time in total.

darklordnd
Posts: 4
Joined: Mon Aug 02, 2010 7:28 am

Postby darklordnd » Tue Aug 03, 2010 3:51 pm

Again thank you for your kindness of helping me in such details. I tried every compatibility mode possible, and I always (right after installing windows) turn off every security stuffs like firewall or account manager, etc. because they annoy me all the time. I leave only my antivirus software on guard at all time.
I do not have (or do not know) a choice of running the application in 32 bit mode.

Keith
Posts: 9965
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Tue Aug 03, 2010 10:41 pm

If you connect to the internet with broadband DSL or cable, turn off your router box to disconnect from the internet. This will keep you from getting any incoming hackers or probes when you do the next step.

Then turn off your anti-virus software as well. If are going to get a virus chances are it's probably already on your system just waiting to go active anyway. Turning off the A-V software let's us see if it is the cause of your problem. Many such A-V programs have problems running games.

Then try the game.

You can turn it all back on later.

darklordnd
Posts: 4
Joined: Mon Aug 02, 2010 7:28 am

Postby darklordnd » Wed Aug 04, 2010 7:13 am

well, at the peak of confusion and the destruction of patience, I decided to install windows xp 32 bit as a second OS for my computer. Now I have two windows. And the windows xp 32 bit works Caesar out with no problem. I think it's kind of windows 7 stuff. it still annoys me when having to restart before playing the game, but at least it works. I'm still in search of a better solution, so if anyone come up with one, please post it here and there would be great thanks from me and some of my friends who are using the same windows 7 version.

Tinkerbell
Posts: 5415
Joined: Fri Sep 07, 2007 3:42 am
Location: San Diego, California
Contact:

Postby Tinkerbell » Wed Aug 04, 2010 3:18 pm

Howdy, darklordnd!

I don't know what to say. My C4 works great on my W7 Home Premium 64. No run as Admin, no compatabitlity changes, nothing.

You doing all the W7 autoupdates?


Return to “Community Technical Support”

Who is online

Users browsing this forum: No registered users and 2 guests