did work - now it doesn't.

Need help or want to discuss strategy? This is the place!
pawz
Posts: 4
Joined: Wed Jun 26, 2013 2:16 pm

did work - now it doesn't.

Postby pawz » Wed May 27, 2015 10:28 am

hello, frustrated here!. I have a 64bit Windows 7 machine, and I have played SimCity Societies - Destinations on it without any problems in the past. I stopped playing for a while, and now, having decided to start up again, I cannot get it to play. I uninstalled Destinations and the original game, ensured nothing was left in registry, installed from the CD - still won't run, tried to reinstall Destinations, but it cannot complete the install, so I guess there is a problem with the original game. I bought a new DVD of SCS and installed from that - no difference. I have the game in compatibility mode and run by Administrator. Don't know what else to do.. and then I thought of you.. ( smiles sweetly). Can you advise please?? :D

Keith
Posts: 9965
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Wed May 27, 2015 12:00 pm

I don't have SCS, so I can't give you very much detailed help.

From your description, you have already done many of the steps that I would have recommended

Since the game was running before, and the fact that the install from the new doesn't want to work, it seems to me that you have installed something new that conflicts with the game in some way. Or, a Windows update may be causing you some problems with the changes it is brought to your system.

One other point is that perhaps your anti-virus software might be conflicting with the game now for some reason. You may want to disable your AV program for a short while to see if you can get the game running.

Do you get any sort of warning message or information from Windows when you try to run the game now?

Or, does the game just try to load and stop for no apparent reason?

pawz
Posts: 4
Joined: Wed Jun 26, 2013 2:16 pm

Postby pawz » Wed May 27, 2015 1:46 pm

I was getting 'can't do this' messages - cannot remember the syntax now. Now I press 'Play!' and the launcher fires up the disk, and then there is just a black screen with the games cursor, which I can move about, but nowt else happens. I will shut down the real-time shield on my security and see if that helps, but not hopeful. I saw someone mentioning removing 'TM' on someother forum I was looking at, possibly Simopolis, when responding to someone else who could not play the game on Windows 8. I take it that is Tilting Mill's mark, but wouldn't know where to find that - and another person said there were .NET issues. I tried getting the .NET 2.0 that comes with the game to install, but it says it is not compatible with x64 bit. I guess the game uses a later version now. I could try installing it on my older 32bit machine, but I feel that is a bit of a cop-out as it was running perfectly happily on this one - so I think, as you say, some update or other has caused some sort of issue or conflict. Thank you anyway Old Bean, appreciate your efforts to help - isn't it odd; the game becomes suddenly so much more desirable when you can't get it to run..... :p

AHA, have got the original game working - had to patch it. I did not remember that! Two patches in fact. Still cannot get Destinations to install though......
Last edited by pawz on Wed May 27, 2015 9:41 pm, edited 1 time in total.


Return to “Game Help & Strategy”

Who is online

Users browsing this forum: No registered users and 1 guest