Page 1 of 1

How can I change the starting cash.

Posted: Sun Jun 29, 2008 3:30 am
by rforeman
Which xml file controls the starting cash? I have both SCS and SCSD.

Thanks.

Posted: Sun Jun 29, 2008 6:18 am
by gwynnblaid
hi, in the installations dir of your scs game search in data\XMLDb\constants\ for the file constants.xml (don't forget to backup your file first!!)

open file and search for that line
<Value type="int" name="StartingSimoleans">50000</Value>

change the amount whatever you wish.

good luck!

Posted: Sun Jun 29, 2008 1:51 pm
by rforeman
Thanks It was driving me crazy trying to find it. :)

Posted: Tue Jul 01, 2008 1:21 pm
by Hilde
I have tried that but can not save the file. Do I open it in notepad or in another program? I have tried in notepad.

Posted: Tue Jul 01, 2008 2:07 pm
by gwynnblaid
the file is read-only protected. Right click the file and uncheck the read-only. then u can save it. :)

Posted: Tue Jul 01, 2008 3:20 pm
by Hilde
Still cannot save. It says:Cannot create the C :P rogramfiles(x86)\Electronic Arts\SimCity\bla bla and so on.

Make sure that the file and the path name are correct.

I am the admin on this computer so that can not be the problem.
I rightclick on the file, open with notepad, do the changes and click yes to save. Then I get the messages Cannot create ...

Posted: Tue Jul 01, 2008 3:24 pm
by panikattak
Are you hitting apply? Because what you're describing is exactly what happens when I run across a read only *.xml file when I try to save it.

Posted: Tue Jul 01, 2008 3:48 pm
by Hilde
Here is a pic of the file, there is no marking in the read-only box.

Posted: Tue Jul 01, 2008 4:41 pm
by gwynnblaid
try to save the file in a different folder (try documents). then copy it to the appropriate folder in the installation folder. it asks if overwrite existing file. hit yes. this could probably work.

Posted: Tue Jul 01, 2008 4:55 pm
by Hilde
Thank you so much, that did it :D . I remember getting this choice in one of many tries but had not the nerv to do it lol. Thank you again.

Posted: Tue Jul 01, 2008 4:58 pm
by gwynnblaid
you're welcome :D

Posted: Tue Jul 01, 2008 6:23 pm
by GTNS
You'd have to launch Notepad as an administrator. Vista does not allow programs to save files in Program Files or sub-directories, if they aren't running in elevated mode. ;)

Posted: Tue Jul 01, 2008 7:04 pm
by gwynnblaid
hilde was the administrator, but it still didn't work.
I had to uncheck the read-only protection and then it worked. and I am also the administrator of my vista.

Posted: Tue Jul 01, 2008 11:18 pm
by GTNS
But in Vista, even if you are the administrator, unless you run an application as such, it can't write in some places. I am the administrator too, but when I want to modify SCS XMLs quickly, I right click on notepad and choose Run as administrator. I didn't know removing the read-only protection would acheive the same effect. :)

Posted: Wed Jul 02, 2008 9:17 am
by Hilde
I remember my son said to me when I installed Vista that I had to run as admin but I forgot about it. Thank you for reminding me GTNS. :)