Building IDs and Placement Previews

For discussion and help on modding and customizing the game
Sandra Linkletter
Posts: 693
Joined: Tue Jul 15, 2008 7:19 pm
Location: Iowa, USA [Catophilopolis, Amundeir 122 S]
Contact:

Building IDs and Placement Previews

Postby Sandra Linkletter » Sat Mar 13, 2010 4:08 am

It seems that once a building ID is ever used, the placement preview for that first building is what appears for whatever building is eventually using that ID. This is a real nuisance. Removing the mod and running the program without it, then replacing the mod with the correct definitions and running it again, did not do the trick. The program apparently doesn't remove unused IDs from whatever cache it is using to keep them. Is there any way to force the program to refresh its memory of the previews for the string IDs?

Sandra Linkletter
Posts: 693
Joined: Tue Jul 15, 2008 7:19 pm
Location: Iowa, USA [Catophilopolis, Amundeir 122 S]
Contact:

Postby Sandra Linkletter » Sun Mar 14, 2010 3:55 am

I found the solution to the preview problem. It is a file under XMLDb\Game\Cultural Graphics Effects\. If one edits the building definition to use a different texture file than the one that was working originally, then the preview continues to use the appearance from this file even though the placed building uses the correct skin. Correcting the entry in this file corrects the problem.

Case closed. :)

Azeem
Posts: 3678
Joined: Wed May 05, 2004 9:30 pm
Location: Hetepsenusret

Postby Azeem » Sun Mar 14, 2010 4:57 am

Good sleuthing. :)


Return to “Mods (Discussion)”

Who is online

Users browsing this forum: No registered users and 4 guests