Page 2 of 2

Posted: Sun Jun 27, 2010 6:00 pm
by moonmonika
so your Destinations is playing, too?. Mine isn't, no matter what I do. damn lol

Posted: Fri Jul 16, 2010 10:25 pm
by oratek
Just registered here so I could post on this issue too. Weirdly our installation has been fine until the EA update manage applied a patch and killed it.

I discovered the same solution found here independently and thought I'd add a wee bit more detail.

To check whether this "TM" symbol is the cause of your (anyone coming across this thread) problem, look at the log files (open with browser) in
C:\Documents and Settings\All Users\Application Data\Electronic Arts\EA Core\logs
-- that's the location on XP.

The log file will contain something like:

0 [21:29:25:983] Error Core::CoreService OpenPath_CreateProcess CreateProcessAsUser("C:\Program Files\Electronic Arts\SimCityâ„¢ Societies\SimCitySocieties.exe" -ead_gl_nogenerate ) failed.
1 [21:29:25:983] Error Core::CoreService OpenPath_CreateProcess CreateProcessAsUser FAILED [2: The system cannot find the file specified. ]

Note that the TM symbol has been munged and so the program file can not be found.

To fix I removed the TM symbol as discussed above, but also updated the registry value "Install Dir" in HKEY_LOCAL_MACHINE\SOFTWARE\Electronic Arts\SimCity Societies with the new path - I imagine that gets used by something.

Note to EA: Don't put non-ascii characters in paths.

Posted: Sat Jul 17, 2010 12:21 pm
by moonmonika
thanks I had installed the games without the TM sign and I can at least play Societies, it's very unstable but it plays ever so often.

I do not have a folder C:\Documents and Settings\All Users\Application Data\Electronic Arts\EA Core\logs

There is only SimCity Societies in the Application Data and that one does not have a log file ?

I seem to remember having looked for that file previously in the Windows XP folders, nothing there either.

So I guess I have to do without my Destination, although it did play before my hard drive crashed (Laptop).

Posted: Wed Jul 21, 2010 12:46 pm
by Volitionist
Hey all,
I'm having the same issue: double click on icon, get the launcher, hit "play", nothing happens. The .exe process appears in the task manager process list for a moment, then goes away. There is no error message. If I go straight to the .exe on the CD, it again runs the process briefly, but then I get a Runtime error ("This application has requested the Runtime to terminate it in an usual way. Please contact the application's support team for more information."). My machine exceeds all the recommended system requirements and my drivers are up to date. I went through the whole SecuROM support process (they were very quick to respond and offered several possible solutions, but ultimately they determined the error had nothing to do with them) to no avail.

So far I have tried: uninstalling/reinstalling, doing the install without the TM in the directory name, using a different .exe file provided by SecuROM, applying a Windows hotfix for the Runtime error, and installing on a different computer (my laptop could run the game just fine until you tried to do anything, then the on-board video card crapped out as expected...but the game ran, at least). I am currently sending an e-mail to EA to hopefully figure out a fix, but in a hilarious twist of events, I can't get the EasyInfo program to run (they request you use it to generate a system info file for them to analyze). I'm sure that there's something off on my end, but I don't know what it is and I can't fix it. I bought this game for $5 on Amazon just for kicks, and I've now spent over two weeks trying to debug it. NOT worth it.

Posted: Sat Jul 24, 2010 4:05 pm
by moonmonika
I'm sorry you can't get your game to play. does not matter that you got it cheap, it should still work, after all a lot of people paid a lot of money and the game is not playable.

My Destinations does not play, but at least I get Societies to load, is not stable and it's actually not really a joy to play.

I don't know what to suggest, and there does not seem to be anybody here who can help us. :mad:

Maybe I must dust off my Children of the Nile, gosh that is nearly as ancient is the Pyramids, lol.

did you try to copy the game to your pc and then install as suggested here

Posted: Thu Sep 30, 2010 9:19 pm
by marckr32
"Tyrnn" wrote:I looked through the path, and it turns out that the 'trademark' symbol in my directory was causing the snafu. If you installed the game with the trademark symbol in the directory, try uninstalling and reinstalling the game, but without the ™ in the installation path. That fixed my problem.

Ok so given the posts on this are quite old, I am not sure if anyone else has encountered the problem.
Thanks Tyrnn for the heads up.

Just out of curiosity (given I was going to reinstall anyways.) i navigated to the install directory and renamed it by deleting the 'tm' in the folder name. I also right clicked the shortcut created on my desktop for SCS and change the file path 'folder name' to exclude the tm on both target and start in fields. my start in looks like this now "C:\Program Files (x86)\Electronic Arts\SimCitySocieties" . Note that you need to rename your shortcut to exactly what your folder name (renamed above is) .
Worked like a charm and didn't even have to reinstall.
now onto playing the game.

Posted: Mon Oct 04, 2010 4:05 pm
by moonmonika
did all of that, but can't get Destinations to play, Societies plays a bit and then crashes, sometimes I get 30 minutes game play sometimes only 2 minutes.

I think I have to try and find another game which is a bit like this one.

Posted: Mon Oct 04, 2010 8:53 pm
by R8-Q88
What are your computer's stats? I run Windows7 64bit with, AMD Sempron LE-1300 With 2GB System Memory and 250GB Hard Drive, and the game runs fine for me. You could try browsing to where the actual SCS application is, right click on it, click troubleshoot compatability on the drop-down, and go through the steps in the window that pops up. Other than that, I don't know what could be causing your crashes and not-starting game.

Posted: Thu Oct 07, 2010 9:07 am
by moonmonika
I have an Acer Aspire 5020 laptop, XP Home SP 3. Was able to play Destinations in 2008 but had to get a new hard drive this year and I don't know what happened, can't get Destinations to play. Managed to get Societies working. Have tried every trick in the book. So I guess I will have to wait until I replace this laptop, and then battle with Windows 7 lol

Posted: Thu Oct 07, 2010 10:07 pm
by R8-Q88
Well, 7 isn't so bad. I can run SCS at pretty high settings on mine, so it is ok for SCS.

Posted: Fri Oct 08, 2010 3:47 pm
by moonmonika
"R8-Q88" wrote:Well, 7 isn't so bad. I can run SCS at pretty high settings on mine, so it is ok for SCS.

that's great to know. I'll come back and ask all the tricks, when I get a new laptop or pc. Am really toying with the idea to buy one of these tiny notebooks with an external hard drive. I always find them sooo cute, and Acer has one in my fav colour.. purple, lol

Posted: Sat Oct 09, 2010 2:39 am
by R8-Q88
I don't know about some of those notebooks... My school uses some of them and the graphics are HORRIBLE! I mean something like 16bit pixels. Well, those are Lenovos that run on Windows XP SP1. (I know its horrible! I mean, seriously? SP1?) Hopefully Acers are better.