Windows 8 game won't launch

For technical or performance related issues
paokara777
Posts: 6
Joined: Thu Jan 31, 2013 10:41 am

Windows 8 game won't launch

Postby paokara777 » Thu Jan 31, 2013 10:49 am

I recently upgraded my PC from Windows 7 to windows 8,

The other day i installed Sim City Societies (brushed the dusk off the cover and though i'd revisit it since it's been patched etc =] )
Anyways, before patching it i tried to launch it and it came up with a message saying that my operating system was not compatible, and i had to have a 98SE, 2000, XP SP3 or better to contune (or something like that)

I thought that id just try patching it and see if that fixed it...

I downloaded and installed Patch #5, the patch failed after working for about 3-4 mins

I ran the patch again. This time it succeeded, now launching the game works, and for a split milisecond, i even see the simcity blue/purple cursur on a black screen, them it crashes to the desktop.

I have tried all the common fixes like compatibility and right click - troubleshoot or analyse whatever that option is, no luck.

Also i have installed without the TM in the path

Keith
Posts: 9945
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Thu Jan 31, 2013 4:28 pm

I recently have upgraded to Window 8 and had the same sort of problems with two games that ran fine on XP but wouldn't start or would give me the same sort of message that the program "was not compatible with this OS."

From the Win 8 START page type "compatibility", this should bring up the slide menu with the search function at the top where you will see what you just typed.

Chances are by the time you get to "compati" there will be one listing under "Settings" in the right column menu. Click on Settings. If it doesn't show continue typing the search word.

Now you should have a box in the upper left corner of the screen that says "Run programs made for previous versions of Windows." Click on that box.

This should bring up the Program Compatibility Troubleshooter menu on your Win 8 DESKTOP page.

Now if you just click NEXT the troubleshooter is going to use default settings I has to search for your program and attempt to apply fixes to the launch link to make it work. DON'T CLICK NEXT.

instead click the word "Advanced" in the lower left region of the menu.

If you don't see your game's .exe file listed on the list that appears, then choose "Not Listed" and then click NEXT

Then Browse to your game's install folder. Then manually select the game's EXE file. You game will be somewhere in the following path:

Now in the left column click on

Code: Select all

OS (C :)
and then in the right half of the screen click on "Program Files (x86)". Find the folder for Electronic Arts and open it. Then click on the one for SCS.

If you installed in a different location than the default "Program Files (x86)" be sure to browse to your game folder following the path you manually specified.

Once in the game folder select the .exe file that starts the game. Clicking on it will make it appear in the "Filename line" at the bottom.

Now click OPEN. Then when the next menu appears with the game's install path click NEXT.

Select the Windows OS you want to emulate when you get the chance. I would say you would be better off in XP mode for SCS.


Just follow any instructions the utility gives you. As I recall it should launch the game if successful. So be sure your disc with SecuROM is in the cd/dvd drive if the game checks for valid disc.

Also, if the above method fails, retry it. Click on the word "Advanced" again
and on the next screen click on the words "Run as administrator". This will reopen the screen where you have to click on the word "Advanced" again.

Then click NEXT and redo all the steps above from the point where you select "Not Listed" on the list of programs.

Select Windows mode you want to emulate for that game and finish the troubleshooter.

I got both my games running by using the "Not Listed" procedure. Neither one was SCS by the way. One was Caesar IV and the other was from another game company.
Last edited by Keith on Thu Jan 31, 2013 4:32 pm, edited 1 time in total.

paokara777
Posts: 6
Joined: Thu Jan 31, 2013 10:41 am

Postby paokara777 » Thu Jan 31, 2013 11:20 pm

Wow that is some guide for a simple compatibility mode!

Anwyays, in my original post i stated that "i have tried all common fixes, like compatibility"

Its the second last line of my OP

Thanks anyways though, Anyone else have any solutions?

Keith
Posts: 9945
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Fri Feb 01, 2013 12:37 am

No. Like I said, I was getting the same error message about the OS and running the "Not Listed" procedure fixed it for me. I had to literally point the compatibility utility to my "wic.exe" file in my World in Conflict install folder and I had to use the "run as administrator" option as well.

If you have tried the automatic method, the "not listed" method, and the "run as administrator" "not listed" method I'm out of ideas.

I don't work for Tilted Mill. I'm just a gamer like most here. Tilted Mill only developed the game for Electronic Arts. Officially technical support was supposed to come from EA.

I hope you find a way to get it going.

paokara777
Posts: 6
Joined: Thu Jan 31, 2013 10:41 am

Postby paokara777 » Fri Feb 01, 2013 1:27 am

yeah but EA support is like blood from stone for that game. They seemed to abandon it a week after its release

paokara777
Posts: 6
Joined: Thu Jan 31, 2013 10:41 am

Postby paokara777 » Fri Feb 01, 2013 1:28 am

I will try your suggestion though and get back to ya

paokara777
Posts: 6
Joined: Thu Jan 31, 2013 10:41 am

Postby paokara777 » Fri Feb 01, 2013 1:34 am

OK tried your solution, it was one of the methods i have already tried.... When the wizard appeared i recognised it and have run it. It suggests Windows XP SP3 mode.

Im goign to try uninstalling and reinstalling...

Keith
Posts: 9945
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Fri Feb 01, 2013 4:00 am

Well, good luck. I have a hunch that you might get the same error message though.

You can always try running the Setup.exe file on the game install disc through the Program Compatibility Trouble shooter and have it set to Win XP for the purposes of the install just in case that might help. You may still have to run PCT on the game .exe file after the install if you still have problems.

paokara777
Posts: 6
Joined: Thu Jan 31, 2013 10:41 am

Postby paokara777 » Fri Feb 01, 2013 1:14 pm

No good. It may be a problem with Windows 8 or 64 Bit
Or maybe combination of both.

I installed the game on an old laptop i have that is running Win 7 32bit and it works fine. Still cant get it running on my gaming rig though...

Seriously thinking about dual boot / windows 7.

Has anyone got this game to run on Windows 8 yet?

Keith
Posts: 9945
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Fri Feb 01, 2013 10:21 pm

I guess it's just hit or miss on what games the Program Compatibility Troubleshooter can help. I'm running a 64-bit Win 8 machine myself.

When I ran into my problem and used PCT, I let it choose and apply the fixes automatically, I just used the "Not Listed" option to point it to the actual EXE file. I did not even look at the manual settings for the fix when it asked if I wanted to let it run automatically or if I wanted to choose the fixes applied option. I just let it run automatically.

How old is your computer? Do you still have technical support from the manufacturer on it?

You might want to give them a call and see if they can help you out too. They might as well be miserable too. :)

Keep trying.

bfjl86
Posts: 1
Joined: Wed Feb 13, 2013 5:23 pm

Postby bfjl86 » Wed Feb 13, 2013 5:29 pm

"paokara777" wrote:yeah but EA support is like blood from stone for that game. They seemed to abandon it a week after its release


i find i'm having trouble just finding the patches, or notes from Tilted Mill OR EA but i'm having an issue with Win8 where it says "conflict with emulation software detected" even though i have no emulation software running.

does Win8 have emulation software that is running? and if so how do i disable it?

Keith
Posts: 9945
Joined: Wed May 05, 2004 4:00 pm
Location: USA
Contact:

Postby Keith » Wed Feb 20, 2013 1:55 pm

I don't have SCS, but I do have Win8. It might be some sort of problem with old SecuROM security.

If you right click on your SCS icon on the desktop does it have "Run launch analysis" listed as one of the right-click options?

If it does, click on that and let the program run. It will create a file called "Analysis.sr0" in the C:\ folder of your hard drive.

Zip that file up. The attach it to an email addressed to support@securom.com.

In the email give the name of your game and describe the problem you are having with Win8.

If the problem is being caused by SecuROM they will send you fix.



Also...

Have you tried running the game in the WinXP compatability mode? Use Windows Program Compatibility Troubleshooter utility.

Go your Win8 START screen. Now just type "compatibility". Click on the SETTINGS in the right column. It should be showing 1 app. In the upper left you should see a option listed to run older programs. Click on that.

On the PCT menu, click on NEXT. See if you game is listed on the list of items it presents. If it is select the game from the list and let it try to start the game for you.

You can also run the PCT, and if the game still won't start with the automatic fix method, choose "NOT LISTED" from the list. I got two of my old games to run on Win8 by using that method.


Return to “Community Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest